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Overview
Upon completion of this workshop you will be… 
· Familiar with creating and customizing projects for After Effects CS3
· Familiar with the tools needed for advanced special effects projects in After Effects CS3
· Able to export the project for video editing in a video editing application such as Premiere Pro CS3 or Final Cut Pro

If you need additional assistance following this workshop, please contact the Student Technology Center at 360-4300.
Download Class Files

Sample files for this workshop are available on the Student Technology Center website. To download workshop files:
1. Go to www.wwu.edu/techcenter
2. Click the Workshop Files link
3. Click the After Effects link
4. Choose Run to download the class files.

The files will be downloaded to a folder on your desktop named Training Temp.
Overview of After Effects
	Adobe After Effects CS3 Professional is a powerful special effects program that is part of Adobe’s Creative Suite 3. After Effects allows you to create special effects for already-captured footage and then add special effects, including but not limited to color correction and keying, as well as effects such as lightning, particle effects, etc.  With After Effects at your side and a creative mind, many effects previously thought only to be possible with propriety applications used in Hollywood are now available to the indie filmmaker. Because of After Effects’ advanced role in the video editing process, it is highly recommended that you have experience in an advanced video editing application such as Premiere Pro or Final Cut Pro or a vector-based animation application such as Adobe Flash before attempting to learn After Effects.


Intro to the Workspace
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Overview of Concepts
 	Adobe After Effects projects are saved as After Effects project files with the .aep extension. Although many of the concepts in After Effects are similar to those of video editing, After Effects in and of itself is not a dedicated video editing application. As such, unlike most video editing programs, After Effects does not use pre-rendered files, making the project size very small. The tradeoff to this is that memory usage is very high and After Effects benefits greatly from large amounts of system memory. 

Inside of each After Effects project file, we have what is known as a composition. A composition is a set of effects applied to different objects within that composition over a period of time. Objects inside of compositions can be images, video, flash movies or many other different types of media, even including other compositions. If you have used a video editing program before, compositions are somewhat analogous to separate sequences or timelines. However, the attributes of each composition can vary from each other, including resolution.

Windows in the Workspace
1. The project window contains assets used in each project and is virtually the same as the assets window in Premiere Pro. Here, any objects used in our project, including objects imported into After Effects as well as separate compositions, are displayed here.
2. The tools bar contains a variety of tools for moving and editing objects in compositions. We will discuss this bar later.
3. The composition viewer shows us a preview of the composition we are working on.
4. Play controls allow us to play, rewind, fast forward, pause or stop the composition we are editing.
5. The composition timeline is a graphical representation of the edits that are being made to our project. The blue triangle located at the top of the project, known as the guide, indicates the current frame that is being displayed in the composition viewer. It will move from left to right as the video is being played after pressing ‘play’ in the play controls window.

Beginning a Project

[image: ]New Compositions
1. Click Composition > New Composition to create a new composition. Every After Effects project must have at least one composition; otherwise, you won’t be able to do anything!
2. The composition settings window will pop up (this window can be reached again later by right-clicking on the composition in the project window and clicking ‘settings’ or  by clicking Composition > Composition settings). The composition settings window lets us change various basic aspects about our composition, including resolution and frame rate. By selecting a preset at the top which matches the format that your camera shot in (such as HDV or DV), you can ensure that your composition will match that format. That way, when you’re done with your composition, you can ensure that it will match the format of the video you’re editing in a video editing program.


Importing Files
 	Importing files into After Effects is relatively easy:
1. First, press File > Import > File or File > Import > Multiple Files, depending on whether or not you are importing more than one file.
2. The file you have selected to import will now be located in the project window.
3. Additionally, if you have not yet captured your video from a video program, you can press File > Import > Capture using Premiere Pro, which will open up Premiere Pro so that you can capture the video.
4. Note on audio tracks: You can import audio tracks into After Effects. However, these aren’t specifically for audio editing purposes, but to sync various aspects of an audio track to other effects (more on this later).

Creating New Objects
[image: ] 	Some objects can be made entirely within After Effects. To make a new object, click on Layer > New. This menu gives us options for creating new objects which include solids, text layers, lights, cameras, null objects, adjustment layers and shape layers, most of which will be explained later. It is important, however, to note that, unlike imported objects, new objects will not be added to the project window. This means that if the object is ever deleted from the composition, it cannot be re-added. 


The Viewer
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Viewer Overview
 	The composition viewer shows you what your composition looks like at the currently displayed frame. Note that, because many effects in After Effects cannot be displayed on the fly, the view in the composition viewer might not be fully representative of the finished product.
 	It should also be noted that the viewer can also view certain objects inside of compositions. To do this, you will double-click on the object inside of the timeline window and it will be displayed. To switch back to the full composition view, simply select the correct composition tab. In the picture below, a “solid” object is selected. When an object is selected (rather than a timeline), a bar is displayed at the bottom of the viewer window. By selecting and moving the playhead, we can scrub through the object to see how it looks over time independent of other objects in the composition.

 	Also useful when using the viewer are the zoom tab and the grid options button. With the zoom tab, we can zoom in on what is being displayed in the timeline window. In case you ever are in a spot where you need to make precise measurements, then using the grid options button to turn on either the grid or rulers might be an option.

Moving / Resizing Objects in the Viewer
Many objects (and, as we will see later, effects) can have their position moved directly in the
viewer. They can also be resized.
1. Click on the object in either the viewer or the timeline window.
2. [image: ]A set of points should appear on each corner of the object, as well as crosshairs in the center.
3. Click and drag the crosshairs to move the object.
4. Resize the object by clicking and dragging the points along the edge of the object. To maintain aspect ratio (keep the same shape) as you are adjusting the image, begin resizing the image and then press shift before releasing. This will snap the object to the aspect ratio it was before adjusting.



The Toolbox
	The toolbox is by default located in the upper right-hand corner of the workspace. These following are the most commonly used tools. The other tools can be gotten used to through use of effects which involve them.

· [image: ]Selection tool: This is the ‘default’ tool in After Effects. Any time we want to work in the timeline or move the location of objects, the selection tool must be used.
· [image: ]Hand tool: This allows us to drag around the view of the composition in the viewer without moving any objects.
· [image: ]Zoom tool: This tool allows us to zoom in or out (out by holding the alt key). It is analogous to using the zoom tab in the viewer.
· [image: ]Type tool: This tool allows us to create and edit new text objects.
· [image: ]Brush tool: This tool allows us to draw new vector-based objects directly into the viewer, much like we would in a program like Adobe Illustrator.
· [image: ]Eraser tool: Used for erasing paths. Interfaces well with the brush tool.

Adding Text with the Type Tool
	If you have used an application such as Adobe Photoshop before, adding text into your After Effects composition is done much the same way.
1. Select the type tool.
2. Select within the viewer to bring up the cursor. You can now begin typing text into the viewer.
3.  On the left hand side, the character window should pop up. If it does not, it should be accessible by clicking Window > Character.
4. Inside the character window, you can change many properties of the text such as size, and font. The text must be selected by clicking and dragging within the text object in order for the settings to change.
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The Composition Timeline

 	Much like the timeline of a video editing program, the composition timeline in After Effects is the single most important window in the entire program. With it we will be adjusting most of the effects that we will be using in our project.

 	After we create a new composition, a corresponding timeline for it will be made in the timeline window. Each composition has only one timeline. From there, we can drag objects directly into the timeline window to start working with them. The picture below shows a typical timeline window after several objects have been inserted. One is an image file dragged from the projects window, while the other three were objects created within After Effects.
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Using the Timeline
· Composition Tabs:
The composition tabs allow you to switch between the timelines of different compositions that may be contained within your project.
· Playhead:
By moving the playhead, we can scrub through our project. The viewer will show whichever frame is bisected by the red line coming down from the playhead. 
· Time at Playhead:
The current time at the playhead will be displayed in blue in the upper-left-hand corner of the timeline window.
· Hide Video Buttons:
The hide video buttons allow us to hide an object from view inside the viewer. This does not delete the object. However, if the project is rendered with an invisible object, the invisible object will remain invisible. By pressing the hide  video button for the hidden object again, the object will become visible.
· Objects:
Each object will be displayed here to the left of its representation in the timeline. Its
name will be displayed under “source name.” We can select an object by clicking its name. By pressing the triangle button, that object will become expanded; whatever effects we have already applied to the project will be displayed by expanding it. We can press the triangle again to collapse it. Furthermore, effects can also be expanded or collapsed to view their internal properties, which are editable. It should be noted that, like video editing programs such as Premiere Pro, objects that are located higher in the order will occlude (obstruct) lower objects, with the lowest object being covered by all the objects above it and the topmost object being completely unoccluded.
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· Object-Specific Settings:
Each one of these buttons apply their own special state to an entire object. They are also known as ‘switches.’ If you do not see them in your timeline window, simply right-click next to the source name panel and click Columns > Switches. They are:
· [image: ]Shy: This button will turn on the ‘shy’ switch. If the Hide All button is pressed (located just above the parent settings pane), then all objects with the ‘hide’ switch turned on will be hidden. This feature comes in handy if you have a project where many parts have already been completed and you only want the parts you are working on to appear in the timeline.
· [image: ]Collapse Transformations / Continually Rasterize: This setting only applies to precomposition layers and vector graphics layers (such as shapes, text or documents imported from a vector graphics program). 
· [image: ]Quality: Changing the setting here is only recommended if you are running into big performance problems, as it will degrade the quality of that object you are working with.
· [image: ]Effects: Changing this switch will toggle on or off all of the effects associated with that object.
· [image: ]Frame Blend: Specifies the frame blending mode used by the renderer within After Effects. By applying frame blending, movie clips that are interlaced or otherwise have a low framerate can have their movement ‘smoothed’ by After Effects by averaging the fields belonging to two frames and then inserting the new frame in between the two existing frames. Only applies to movie footage.
· [image: ]Motion Blur: By turning this on, After Effects will simulate the shutter behavior of a camera in that moving objects will be blurred along their axis of movement. The ‘enable motion blur’ button located above the parent settings tab must be also be enabled.
· [image: ]Adjustment Layer: This switch turns the object into an adjustment layer.
· [image: ]3D Layer: This switch turns the object into a 3D layer, which can be effected by other 3D layer objects.
· Parent Settings:
Here, you can make one object the ‘parent’ of another object. Parenting an object to another makes the object a ‘child’ object. Changing the properties of the ‘transform’ effect in the parent object will do the same in the child objects.
· Work Area Specifier:
The work area specifier specifies the actual length of the composition. By bringing the mouse cursor over the edge of the right-most blue bar of the work area specifier, we can make our composition either longer or shorter. We can do the same to objects, but there is no reason to extend an object past the end of the work area specifier since the composition ceases at that point.

Working with Effects

	What allows After Effects to shine is the ability to apply special effects to objects located in the timeline window and then to animate properties of those effects over time. 
	After Effects divides its effects into two categories: inherent effects and user effects. Inherent effects are effects which are automatically attributed to an object. The transform effect, which houses properties such as the opacity and position of an object, is automatically applied to nearly every object. This way, if we wanted to change the position of the object, we can edit the position in the transform effect. When we were moving the object in the viewer window earlier, all we were doing was change the position property in the transform effect.
[image: ]
Applying an Effect
1. First, find the ‘effects and presets’ window located in the right-hand portion of the workspace.
2. Here, effects are grouped in categories based on their behavior.
3. Once you have found an effect that you wish to apply to an object, simply click and drag that effect on top of the object in the timeline window.
4. In the timeline window, when viewing the expanded view of the object, the new effect will appear under ‘effects.’ All effects applied by the user appear here.
5. To delete an effect from an object, simply click on it and press the delete key.


Animating Effects
[image: ]	Effects within an object can have certain properties changed over time through a process which uses frames known as keyframes. What keyframes allow us to do is define properties of different effects at set points in the project and then have After Effects do the rest of work by changing the settings in between the two keyframes, creating a smooth transition. If you have used Flash before, the animation process in After Effects is very similar to its tweening process. It is also similar to animation in Premiere Pro.
1. First, click the ‘toggle animation’ button located next to the property that you wish to add keyframes to. A keyframe will be added to wherever the playhead is currently located.
2. Scrub along the timeline using the playhead until you reach the spot where you want to add the second keyframe.
3. Click the ‘add keyframe’ button. Note that you can scroll through keyframes by using the keyframes scroller buttons.
4. Scroll to both keyframes and change their properties so that they are different from each other.
5. There will now be a smooth transition in the space between the keyframes. If we are editing the position of the object, then the object will appear to move between the two positions specified by the two keyframes in the area between the two keyframes. Experimenting with keyframes is key to mastering After Effects.
6. If you wish to delete a keyframe, click on the keyframe and press the delete key. Pressing the toggle animation button again deletes all keyframes.

Pick Whipping Properties
	As you work more and more on After Effects projects, you might find yourself replicating lots of keyframes – that is, you want similar effects to be happening at a similar time. If you want, say, the text to move along with an imported image, what are you supposed to do? This is where pick whipping comes in and it is an essential tool within After Effects. Use of the pick whip can sometimes separate the novice from the master.
	Pick whipping allows us to take one property and have it point at any other property within a composition. This way, we can have the position property of one object point to the position property of another object, and they will always be in the same position.
1. Click on an object’s name in the timeline window while pressing ALT. The expression editor will now pop up.
2. Click and drag the pick whip until the other end is physically touching the name of the other property you want it to point to.
3. Click outside of the expression editor to apply the custom expression.
	
[image: ]

Note that more can be added to the custom expression defined by adding to the end of it. If we wanted to completely reverse the value from what we were pick whipping, for instance, we would add *-1 to the end to multiply it by -1. If we wanted to be even more adventurous, we could multiply certain properties by other properties all in the expression editor. 



Common operators used when using the expression editor:
	Addition: +
Example: transform.position[0]+200
(will add 200 to what is received from the position property)
	Subtraction: -
Example: transform.position[0]-200
(will subtract 200 to what is received from the position property)

	Multiplication: *
Example: transform.position[0]*-1
(will multiply what is received from the position property by -1)
	Division: /
Example: transform.position[0]/2
(will halve what is received from the position property)



3D Layers

3D Layers in After Effects are objects that move around in a set 3D space unique to the current composition. 3D Layers only change each other; layers that are not 3D are not affected. Remember that in order to change a layer from a 2D one into a 3D one, you must turn the 3D layer switch on.

Moving 3D Layers
	After an object has become a 3D layer, you get more freedom in how it is moved; instead of moving in two dimensions, it can now be moved in three.
1. Select the 3D layer object.
2. A 3D rotation axis will appear in the corner of the screen. Notice the adjustment markers are otherwise present, making resizing the same as with 2D layers.
3. [image: ]To move the object, click on the arrow associated with the direction that you want to move the object in and drag, releasing when the object is in the desired location.

Cameras
	Cameras are creatable layer objects that are always 3D layers. By changing the properties of the camera (located under transform), the view of the 3D space is changed. The images below are taken with cameras at different positions, but with the same objects at the same properties. Remember that, like other objects, cameras can have their positions animated over time by adding keyframes. This way, you can make a project in which the camera moves through a 3D scene of objects.

Lights
	Lights are 3D layers that apply lighting effects to other 3D layers. Under transform, the properties of the light such as its color and position can be changed. Because lights are 3D layers, they only illuminate other 3D layers. They do not affect 2D layers.


Exporting Compositions

	The After Effects project file only contains data native to After Effects. In order to put the project into a state in which it can be used in another program, it must be exported. The currently selected composition will be the one exported by doing the following method.

Image Sequence
	The preferred exportation method in After Effects is to export the entire composition as a long series of images.
1. Press File > Export > Image Sequence to bring up the export window.
2. Confirm the settings, and then press OK.

Other Formats
	After Effects can also export to different movie formats by pressing File > Export, but its support for many formats is limited. It is instead recommended to export as an image sequence above and then import it into a video editing program before exporting as a movie in that program.
Congratulations
You have completed the After Effects CS3 workshop. If you need further assistance with your special effects projects, please contact the Student Technology Center.

Resources 
Tech Center:	http://www.wwu.edu/techcenter
Class Files:  	http://www.acadweb.wwu.ed/stc/website/workshop_files.asp
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